Schall Alien Tech


Vanilla-friendly extension of weaponry. Not overhaul. Adds alternate weaponry choices from mid-game, which is based on the alien science pack from “Schall Alien Loot” mod. Balanced with vanilla weaponry, and extends end-game with MK3 weaponry (including powered armor and tanks). Also adds two featured weapons from “Doom”: Plasma rifle, BFG 9000. (Locale: English, Deutsch, 正體中文, 简体中文, Русский, Português Brasileiro)

3 months ago
0.16 - 1.1
32013

b [Solved] Upgrade to Version 0.18.41 (Update Deep Core Mining to 2.3.2)

8 months ago

Hello, when you upgrade Factorio to 0.18.41, Schall Alien Tech throws in the loading screen this Error message out:

Failed to load mods. Error while loading entity prototype "Schall-uranium-mining-drill" (mining drill): Animation speed has to be greater then 0.
At: ROOT.mining-drill.Schall-uranium-drill.graphics_set.working_visulation[0].animation.hr_version

Can you look into this problem and make an update?
Thanks -

8 months ago

I am using this mod 0.18.6 on game 0.18.42 (not on .41 though).
The uranium mining drill is working in my game, without any problem.
Are you sure the problem still exist?

8 months ago

Yes, its still there, even with 0.18.43:

Failed to load mods: Error while loading entity prototype "Schall-uranium-mining-drill" (mining-drill): Animation speed has to be greater than 0.
At ROOT.mining-drill.Schall-uranium-mining-drill.graphics_set.working_visualisations[0].animation.hr_version
Modifications: Schall Alien Tech

Mods to be disabled:
SchallAlienTech (0.18.6)

8 months ago

I am not sure what has happened.
I played on both "Normal" and "High" sprite resolution settings, and the games load fine with the drills also working.

I have released 0.18.7 for the updated drill prototype definitions in 0.18.44.
Please update both the game and mod, then try again.

If it still not works, I suspect another mod may have interfered and messed up my drill prototype.
Please try disable this mod, and check if any mods have modified the vanilla electric mining drill (by hovering over the item/entity, see if there are any mods listed, in blue text below the item/entity name.) This may suggest which mod(s) are suspicious as the cause of the issue.

7 months ago

Are you using "Squeak Through" mod?
If so, then another bug report could be releavant.

If not, I still need your info, to start guessing what could go wrong.

7 months ago
(updated 7 months ago)

It doesn't seem to be related to Squeak Through. I had the same message as vizthex but upon disabling it the same error appears.
So I played a bit of pingpong with my modlist and found a mod that causes it: Deep Core Mining (https://mods.factorio.com/mod/vtk-deep-core-mining)
No clue what's happening there but DCM added a new kind of mining drill on 04.08.2020. That would fit the OP here quite nicely.

7 months ago

Thanks for the info.
I am not sure about DCM, how or why it caused it. Do not have the time to read the its code.

But yes, outdated code could be a cause.
Vanilla has changed the definitions of mining drills graphics quite frequently just before 1.0 launches. That was why I also made multiple updates to adapt to those changes.
My last update points to 0.18.46, which was released on 2020.08.11. It supports your argument.

PS: Just curious. Does DCM shows up in the game startup error message screen? Or does it "secretly" crashing your startup without being mentioned by the error?

7 months ago

It's indeed secretly crashing it, here's the error with just Alien Tech (+Alien loot +Tank Platoon) and DCM active, same as OP.
https://files.catbox.moe/jfzip0.png

Oh hold on. I poked more and somehow, I'm not getting vizthexs error anymore. Instead Squeak through throws out a new error when loaded alone with Alien Tech but adding DCM lets things go back to normal.
Loading only Alien Tech and Squeak Through:
https://files.catbox.moe/ed8rpp.png

Alien Tech, DCM and Squeak Through (same for just loading my entire mod list):
Identical with the OP too.

7 months ago
(updated 7 months ago)

I see the reason now.
Deep core mining (2.3.1) is secretly adjusting vanilla prototypes (Reference: here), breaking a lot of mods (this mod is only one of the victims). This mod is only one of many victims.
Its last update is 9 days ago, so I guess you can hope for an update.

Squeak Through (1.8.0) is very outdated, breaking other mods that introduces mining drills. (Reference: here.)
Its last update is 7 months ago... So I advice you to disable it, or you may need to do a manual fix yourself...

In any case, it is not my or this mod's fault. And I can do nothing from my side.

7 months ago

DCM fixed it on their part, so the problem should be gone now. SqT still breaks as expected but yeah, nothing Shall can do about it.
Error message for that one complains about both Alien Tech and SqT so people might still end up here looking for help.

7 months ago

Thanks for notice. Users of DCM should update to 2.3.2.

New response