Schall Alien Tech


Vanilla-friendly extension of weaponry. Not overhaul. Adds alternate weaponry choices from mid-game, which is based on the alien science pack from “Schall Alien Loot” mod. Balanced with vanilla weaponry, and extends end-game with MK3 weaponry (including powered armor and tanks). Also adds two featured weapons from “Doom”: Plasma rifle, BFG 9000. (Locale: English, Deutsch, 正體中文, 简体中文, Русский, Português Brasileiro)

3 months ago
0.16 - 1.1
31881

b [Solved] Crash on load in Factorio 0.17.35

1 year, 11 months ago
  56.260 Mods to disable:Failed to load mods: __SchallAlienTech__/data.lua:10: __SchallAlienTech__/prototypes/armor.lua:1: attempt to index field 'player' (a nil value)
stack traceback:
        __SchallAlienTech__/prototypes/armor.lua:1: in main chunk
        [C]: in function 'require'
        __SchallAlienTech__/data.lua:10: in main chunk
stack traceback:
        [C]: in function 'require'
        __SchallAlienTech__/data.lua:10: in main chunk
1 year, 11 months ago

Do what factorio patch notes and this error message tell you: replace 'player' by 'character' in armor.lua.
SchallArmouredTrain_0.17.2.zip and SchallTankPlatoon_0.17.4.zip also require small fixes after game patch release.

1 year, 11 months ago

Should be fixed in recent version 0.17.5.

PS: Please understand that not every modder is 24/7 ready for modding. Modding is only one part of my life. Usually weekend is my family time. I had neither the time nor mood to sit in front of computer to do the modding, although it may seems trivial to fix the mods. We may not be even staying at home. In that case, all I can do is to read messages and do some simple replies.
Like the past version 0.17.23 about contiguous levels and likely in the future also, I cannot respond quickly to these mod-breaking game version released on Thursdays and Fridays. I can only work on updates starting from Mondays.

1 year, 11 months ago

Like the past version 0.17.23 about contiguous levels and likely in the future also, I cannot respond quickly to these mod-breaking game version released on Thursdays and Fridays. I can only work on updates starting from Mondays.

All good, thanks for that! :-)

1 year, 10 months ago

Thanks for what you do here, Schall! Those of us who don't know how to fix it ourselves will just stick with an older version for now.

1 year, 10 months ago

The recent version 0.17.5 should have already fixed it. Please try!
This update (also for my other mods) should work with game versions 0.17.35 to 0.17.38.

New response