Schall Recipe Scaling


Adds scaled up version of recipes, in order to get around the game limitation (60 crafting per second) faced by very high speed machines. This allows for true mass production under healthy UPS. Designed for supporting scaled up machines from “Schall Machine Scaling” mod. (Locale: English, Deutsch, 正體中文, Português Brasileiro)

Content
3 years ago
0.17 - 1.1
10.4K
Manufacturing

b [Solved] Angel mods causes error

4 years ago
(updated 4 years ago)

I am using the game version 17.79
Running along with the Angel's Refining and Angel's Smelting mod causes an error.

Error in assignid, element named 'Angels-Electric-Boiler' does not exist.
Source: angels-electric-boiler-RS (recipe).

4 years ago
(updated 4 years ago)

Error in assignid, element named 'Angels-Electric-Boiler' does not exist.

Have you edited the error message? To what I know, Angel's entities do NOT have capital letters.
Was it displayed as the following instead?

Error in assignid, element named "angels-electric-boile" does not exist.

If so, please do not do that. Any edits will conceal the true problem, as shown below...

Angel's electric boiler do NOT exist in Angel's Refining nor Angel's Smelting neither.
I found it in Angel's Petro Chemical Processing instead. There are TWO recipes for it, and one of them is MISSPELLED. I am not sure if this is the source of error.
petrochem-entity.lua line 535
petrochem-entity-angels.lua line 1269, 1282

Maybe Angel's mods will override the first (misspelled) recipe with the second (correct) recipe at a later data stage. So using Angel's mods alone has no error. Probably my mod copied from the first recipe, so causing the error.

BTW, I am not playing any overhaul mods at all. (Not with this laptop, or in near future.) The above search (including search in the two irrelevant mods) took me more than an hour.
Therefore, I guess it would be wise not to provide any support at all to overhaul mods. Really taking too much time just to crawl the code.

4 years ago
(updated 4 years ago)

Sorry, the previous message was not copied from the log.
Here's how it looked at boot, as well as what was in the log.
https://cdn.discordapp.com/attachments/447413398695706645/678345165999439902/5.PNG
This mod has dependencies so it was automatically turned on
https://cdn.discordapp.com/attachments/447413398695706645/678348373270593556/2.PNG
All other mods have been disabled.
https://cdn.discordapp.com/attachments/447413398695706645/678355590732447774/factorio-current.log

Thanks. I corrected a mistake in the text after which the game started successfully. I will inform the mod developer about the error.
True, other errors with large mods appeared, lol

4 years ago
(updated 4 years ago)

The error was also caused by a bunch of 2 large mods. Separately, they did not cause problems.
Specifically, when starting these.
https://cdn.discordapp.com/attachments/447413398695706645/678361224161001489/3.PNG
https://cdn.discordapp.com/attachments/447413398695706645/678360290248884290/1.PNG
https://cdn.discordapp.com/attachments/447413398695706645/678360332183535616/factorio-current.log

I also tried including all of Bob's mods, as well as a bunch of other mods. Disabling only https://mods.factorio.com/mods/Bobingabout/bobplates and the game started correctly.

4 years ago
(updated 4 years ago)

It sounds like mods trying to alter recipes in `data-final-fixes' stage.
(Many such large / overhaul mods do not obey the normal rules of different data stages.)

Please try the following fix:
1/ Decompress my mod and rename file data-updates.lua to data-final-fixes.lua, see if this helps.
2/ If that is not enough, try adding optional dependencies to info.json of my mod, to ensure my mod loads after them.
The syntax would be like the following. Add entries with names of those mods shown in error message:

"dependencies": ["base >= 0.18.0", "? SchallMachineScaling", "(?) SchallTankPlatoon", "(?) angelmodxxx", "(?) bobplates" ]

4 years ago

The first point was enough. The game started successfully. Other major mods did not cause problems, and a large number of mods also did not cause problems.

https://cdn.discordapp.com/attachments/447413398695706645/678372965913591858/factorio_2020-02-16_01-51-47.png

Thanks for the help, I really liked your mod, I will be very happy to play with it.

4 years ago

Good to hear it works for you.
Perhaps I will make it as official fix soon, in the next release,

4 years ago
(updated 4 years ago)

Everything worked and only I wanted to start ..
Wait what?
https://cdn.discordapp.com/attachments/447413398695706645/678397796927275038/nowhere50.png
Made in: nowhere
Seriously, I can't even do it with my hands?

The problem persists for all recipes; you can’t also craft new recipes with your hands. Mods recipes also fail.

I turned off all the mods, leaving only the original game and Schall Recipe Scaling, the result was the same
I also deleted the mod and downloaded it, the result was the same
I also thought it might be a visual mistake, but when I got to the technology and actually got it, the recipe didn’t appear
Game Version for 17.69, 17.79 and 18.6, the result was the same
Mod version 0.17.0, 0.17.1, 0.17.2, 0.17.3, 0.18.0 the result was the same
Reinstalling the game and completely clearing the AppData\Roaming\Factorio folder did not produce any result...

I checked each version with a new game, developing the first technology to make sure that the problem really remains.

It is still not working
Maybe I'm doing something wrong ..
Anyway I need to sleep
But I still intend to play with this mod ..

4 years ago

Please read the Information page. Very often I typed walls of text to mention the features for each of my mods.

Usage
Upon enabling this mod, an extra set of recipes would be added to your game. They are designed as machine-only recipes, so will not appear in player handcrafting menu. You will only see them in the specified machines, which are set in options "Machines using scaled recipes", under "Options" → "Mod settings" → "Startup" tab.
Default value is "*-MS-[3456789]$", which supports all overtier machines of +3 or above, from Schall Machine Scaling mod. This field can be modified or added. Just be sure all entries are separated by comma and space. Supports most Lua patterns, can use * as wildcard.

If you have Schall Machine Scaling, it should work automatically.
If you don't like that and want to put into machines from other mods, you have to input suitable strings.

There are also a bunch of other options (probably more than any players' need), I guess they should be all well-documented (description text on mouse cursor hover).

4 years ago

Seriously, I can't even do it with my hands?

Think in another way.
If the original recipe gives 1 product in 1 s, and the scaled recipe gives 50 products in 50 s... Why would I apply the scaled recipe with handcrafting? If I ever need to mass produced something with hands, I can just use Ctrl-click (or other key combos) on original recipe, right? No need just for this kind of uses with a new mod.
If scaled recipes show up in handcrafting menu, they will clutter that up. Expect to have double length in each menu...
(Even if I use only my mod set, the vehicles and armament would be too long. It would be horrifying long for overhaul mods users like you. I don't think you will ever want these recipes in your handcrafting menu.)

The real use of this mod is for ultra high speed machines to overcome the 1 crafting per tick (or equivalently 60 crafting per second) limit imposed by game engine.
For example, I have a machine of speed 300. Applying the above-stated original recipe, it would only give 60 products/second, due to the speed cap. Applying the scaled recipe would give the expected 300 products/second.
So this mod is really not for handcrafting.

4 years ago

Thank you, now that I have slept and realized my mistake.
I just let all the machines use advanced recipes.
Now everything works as it should.

But I think you should make sure that by default all machines have access to this mod, because most people just install the mod from the game expecting that the author of the mod made the initial setup, and then they delete it thinking that it does nothing.

https://cdn.discordapp.com/attachments/447413398695706645/678573865533833216/factorio_2020-02-16_15-10-01.png

4 years ago

No, I don't think so.
Low speed machines (including ALL vanilla machines) never need this. The scaled recipes provide no benefits, and only clutter the crafting selection menu. So it is a bad idea to show them in low speed machines. It is doing harm without uses.

I do not play Angel/Bob, Pyrandon, Yuoki Industries, Industrial Revolution nor any other overhaul mods. I do not have the slightest idea what machines in them are high speed. Most of them have nearly zero documentation on what new entities are provided. It is impossible to provide initial setup that suits them. That's why I provided all the mod options for users to have their own settings themselves.
BTW, I expect players on overhaul mods are somewhat "veteran Factorio players", who know to explore mod options and read mod pages. Also I am confident that I am one of the mod authors who provide the most detailed mod description. (I am the type of players: without knowing how a mod does, I won't even bother to download that... I never download and try poorly-documented mods. Alright, perhaps I have expected too much...)
Anyway, if players choose to ignore my description/documentation, really I cannot help.

4 years ago

Just to notice you that I have made the "official" fix in 0.17.4 / 0.18.1 now.
Recipes are generated at data-final-fixes phase, so should work for your mod set.

New response