Titanium

by brevven

Adds titanium ore to the base game. Titanium is mined with lubricant and used in Low Density Structures, Flying Robot Frames and a few other places. Compatible with RSO, Krastorio 2, Space Exploration, and more. A standalone piece of BZ Mods. With graphics by snouz.

2 days ago
0.17 - 1.1
58107

b [FIXED] Nil Value

6 months ago
(updated 6 months ago)

I have all the other BZ mods working fine, only this one chokes up.

I am by no means skilled at understanding the code, and I ask for your forgiveness, but this is what it reads verbatim when attempting to load the mods:


Failed to load mods: bztitanium/titanium-recipe-final-5d.lua:6: attempt to index field 'titanium-plate' (a nil value)
stack traceback:
bztitanium/titanium-recipe-final-5d.lua:6 in main chunk
[C]: in function 'require'
bztitanium/data-final-fixes.lua:20: in main chunk


Any update on what I may be doing wrong would be great! Thank you for your great mods on the other hand!

6 months ago

Hi! Thanks for the report. I am unable to reproduce this issue. I tried with a few different mod lists. Are you able to send me a mod list or a savegame (you can use the forum if you like).

6 months ago
(updated 6 months ago)

Now that you mention my greater mod-list, I am sure that we will find that to simply be the issue. I created a post on the forum and attached my save-file, hopefully that is the simplest way to get my mod-list... since it is quite extensive, but I feel like the the 5d mods may be what is conflicting here somehow.

Forum link: https://forums.factorio.com/viewtopic.php?p=561747#p561747

Thanks for the speedy response!

6 months ago
(updated 6 months ago)

Thanks. Ok, so while I was able to load that particular save, I think it was able to help me fix the problem. I think it occurred when FE+, 5dim's, and Titanium are all used together. The reason the save you sent loaded is because when Bob's is enabled, this adds a different titanium plate that helps prevent the breakage.

I think I've fixed it for the situation you may have faced earlier.

6 months ago

Just got home from work and found that the mods are working perfectly now! Thanks so much for your help!

New response