Schall Recipe Scaling


Adds scaled up version of recipes, in order to get around the game limitation (60 crafting per second) faced by very high speed machines. This allows for true mass production under healthy UPS. Designed for supporting scaled up machines from “Schall Machine Scaling” mod. (Locale: English, Deutsch, 正體中文, Português Brasileiro)

Content
3 years ago
0.17 - 1.1
10.4K
Manufacturing

g [Solved] Disabling Space Science

4 years ago
(updated 4 years ago)

How would I go about disabling modded space science recipes?

Or disabling the mod attempting to scale up any modded recipe?

I wanted to have the multiplier set to 1000 but that sets the alien loot space science to 100,000+ packs and causes a game crash so I'd rather just exclude space science entirely from the recipe multiplier.

How do I do that? No idea what to add/change in the settings.lua?

Thanks!

EDIT: Reading " This mod is smart enough to adjust to lower multiplier values to fit with each item stack size." made no sense as I was getting a crash message saying "Space-Science-Pack-RS" being set to 130,000 stack size and not working.

Solution: It was my alien loot mod where 1 orb = 200 science for some reason was causing this crash. I assume the mod doesn't scale down mod recipes maybe?

Removing that mod fixed it!

4 years ago

Recipes can be excluded by entering the recipe name into mod options field "Exclude recipes". But since you have problem starting, there is not a chance to do that.

What is the exact name of the mods concerned? I want to reproduce the bug, in order to try solving it.
This mod checks against item stack sizes (as in data-final-fixes.lua line 82-99). But the game have at least FOUR ways to define products in a recipes, so I need to see if your case is the FIFTH where I missed, or coming from unusual values of stack sizes.
Could be the game have double standard that allows unusual high stack sizes, but disallows amount of ingredients in recipes. Have to see...

And no, scale down is not possible. (Say, fractional amount of iron plates? Finding "Highest Common Factor" of all the ingredients and products amount? This mod is not a math research software...)

4 years ago

So this is the mod I was using:
https://mods.factorio.com/mod/alien-space-science

I had edited the .lua file to make 1 alien artifact = 200 space science and it worked fine before adding the recipe scaling mod. This mod seems to attach the recipe for this alien artifact to space science WITH the regular space science research/space science recipe so maybe there is an issue there?

I also tried: https://mods.factorio.com/mod/ScienceConversion/downloads

Which also had the same error where the custom recipe the mod was using was being scaled up/boosted into the 100,000+ range [as I have the multiplier on the recipe mod of yours set to 10,000]. The 10,000 multiplier works fine with vanilla recipes as your code that ensures things don't go above max stack size stops issues. [My stack sizes are also set to x100] which works fine as long as I don't have any MODDED recipes added to the game.

Thanks for the fast reply! Fantastic mods by the way :)

4 years ago

Just test and confirmed that the game allows item stack size beyond 65535, while disallows ingredient amount goes beyond 65535. (Feel strange why the game has double standard here...)
So for the items with ultra-high stack size, the items will pass the startup checks, but the recipes will not. This is the source of error.

Please try editing data-final-fixes.lua line 47, replacing:

if list[name] then return list[name].stack_size or 1 end

with

if list[name] then return math.min(amount_limit, list[name].stack_size or 1) end

See if it works for your mod set.

4 years ago

That did it! Fantastic, thank you so much :)

4 years ago

Just released 0.17.5 / 0.18.2. So manual editing is no longer needed now.

New response