Rampant

by Veden
Improves the enemies tactics by using potential fields/pheromones allowing probing of defenses, retreats, reinforcements, counterattacking, breaching, raids, rallying death cry, and player hunting. Uses non-homing blockable biter projectiles. Adds new Enemies (disabled by default). Can completely replace the vanilla AI. Difficulty setting in mod options menu.
a month ago
0.13 - 0.17
136694

b [0.17.14] Error Chunk.cpp:682: Trying to make chunk at unreasonable position [-262083, -262104]

- 6 months ago
(updated 6 months ago)

https://drive.google.com/file/d/14Iu85HeTZeiL6qXe6Id_YAs-5rLemtiJ/view?usp=sharing save
https://drive.google.com/file/d/1Kh2mm0ZdrshoLT7BYpsLCKEo9_B06PkP/view?usp=sharing log, 17.8 version
https://drive.google.com/file/d/1klNsLackkxFVvF2drSbk0vygD4ldc5B2/view?usp=sharing log, 17.9 version
https://drive.google.com/file/d/1ZORlxX1_SpdTg23O7n560sMYuOSHkccv/view?usp=sharing modlist

Rampant 17.8 used currently. Tried the 17.9 version and it Crashed as well.
Disabled all mods, tried to load the save. It loaded. Enabled Rampant, it failed to load, with the same results.

Playing on a hosted, modded server. Game disconnected when i had started walking from main base area to the green chip production area to the southwest, where I had converted it from belts to bots within the last 20 minutes or so. Saved the game locally.
I checked the server status and it had crashed.

I restarted the server with one of the autosaves, and that worked just fine but I had lost progress so I uploaded the locally saved file. Server restarted normally.

Tried to reconnect and the game disconnected immediately after connecting - server had crashed again.

Tried loading up the save file locally. Loading bar filled and the game brought up the error box asking about the log file location.

To my knowledge I wasn't doing anything that would effect chunks, especially not at such an extreme-looking distance away, so I'm at a loss. Log file and a screenshot with the active mods included.
Please let me know if you need more info.

edit: dunno if its relevant or not, but the server went from Factorio 17.2 to 17.14, and Rampant 17.3 to 17.8 two days prior to this happening and had been running just fine up until now.

- 6 months ago

No idea, have you filed a bug report?

- 6 months ago

I had not since it looked like it might be related to your mod. Doing it now.