Krastorio Legacy deprecated


Caution!!! Krastorio 2 is now available! Therefore Krastorio Legacy is no longer supported! This mod expands the endgame, adds 30+ HR buildings, 60+ technologies, new ores, new items and rebalances almost all vanilla game content, making it harder.

1 year, 4 months ago
0.17 - 0.18
123633

b [Fixed] New bug with Factorio version 0.18.2 build 49204

1 year, 4 months ago
(updated 1 year, 4 months ago)

When loading the game with Krastorio Legacy version 1.4.51 enabled in Factorio version 0.18.2 build 49204, an error pops up regarding the heavy gun shot value (image to error can be found here: https://imgur.com/nFSpdNz ). I do have other mods in the game, but none of them to my knowledge changes the heavy gun shot value due to them not being mods that change weapons at all. Every time I try to load the game with the latest version of Krastorio Legacy enabled I get that error, and it only started after Factorio updated to 0.18.2 build 49204 as of the posting of this bug report.

1 year, 4 months ago

The text gist of the error, for brevity sake:
Failed to load mod "Krastorio": Krastorio/data.lua:47: Krastorio/prototypes/item/tank-guns.lua:36: attempt to call global 'make_heavy_gunshot_sounds' (a nil value)
stack traceback:
Krastorio/prototypes/item/tank-guns.lua:36: in main chunk
[C]: in function 'require'
Krastorio/data.lua:47: in main chunk

1 year, 4 months ago

Fixed

New response