HelicopterRevival


Adds a fully animated attack helicopter to the game. Ideal for getting from A to B quickly, exploring the map, building islands and nuking biters from the sky. Originally forked from Kumpu with fixes for Factorio 0.18.2+, but adding some enhancements of my own as well.

5 months ago
0.18 - 1.1
39229

g Help

1 year, 2 months ago

after 18.36 i now get

The mod HelicopterRevival (0.0.5) caused a non-recoverable error.
Please report this error to the mod author.

Error while running event HelicopterRevival::on_configuration_changed
HelicopterRevival/logic/heliBase.lua:6: bad argument #1 of 2 to 'pairs' (table expected, got nil)
stack traceback:
[C]: in function 'pairs'
HelicopterRevival/logic/heliBase.lua:6: in function 'getHeliFromBaseEntity'
HelicopterRevival/logic/gui/gaugeGui.lua:10: in function 'reSetGaugeGui'
HelicopterRevival/control.lua:102: in function <HelicopterRevival/control.lua:55>

1 year, 2 months ago

What was the last version of Factorio that you played?

this looks like a migration issue... Remove the mod and enable it again after the map loaded?

1 year, 2 months ago

0.18.36 build 53200

1 year, 2 months ago

Other mods?
Maybe there's a clash with something else? I tested with the latest and greatest, and -- no issues what soever. I'm gathering as much info as possible...

1 year, 2 months ago

That was a great point, so i uncheck all mods except this one and still the same error.

1 year, 2 months ago
(updated 1 year, 2 months ago)

I just tried verifying game files and deleting the mod folder altogether and making a new one, fresh download of the mod...same result.

1 year, 2 months ago

FIXED I loaded an auto-save and the mod worked fine. I reloaded the game without the mod and found a duplicate me standing there. After killing it with several grenades a saved under a new name, reloaded mod and all works fine. I did need to redo research, but at least it woks.

New response