HelicopterRevival


Adds a fully animated attack helicopter to the game. Ideal for getting from A to B quickly, exploring the map, building islands and nuking biters from the sky. Originally forked from Kumpu with fixes for Factorio 0.18.2+, but adding some enhancements of my own as well.

5 months ago
0.18 - 1.1
38471

b Won't take off [No additional info -- works for me]

1 year, 5 months ago

I've used the old helicopter mod for quite some time with no issues. Came back to Factorio with all this free time in quarantine and got my first helicopter, excited to take flight, except when I get in, it just makes the noises as if it was taking off but no actual animation or movement. I don't think I have any other mods that would conflict, the only thing that likely would mess with the helicopter is Vehicle Grids, but I used that with the original mod with no issue, so I don't see why this fork would suddenly have one. Also, I've noted this says for 0.18.2+ but experimental only goes to 0.18.18 atm, so I'm a bit confused on that as well.

1 year, 5 months ago

I just tested in with vanilla, this mod and Vehicle Grid, and it worked well.
If you're updating from the original Helicopter mod, you may want to deconstruct the old instance of the helicopter and construct a new one.

If that doesn't work, it's highly likely there's a conflict of mod, and I would need to know which mods you are using.

1 year, 5 months ago

I started this save fresh. I guess it must be a mod conflict. I'll take a look at it and if I can't figure it out, I'll come back for help.

1 year, 5 months ago

Well, I was going to just 1 by 1 unload each mod and do a test run, but honestly the loading is far to long for my impatience. If you want to try and help me out, this is a link to my full mod list: https://i.imgur.com/o8MpWcm.png

1 year, 5 months ago

Also, some things to note: if I press W, it does consume fuel, so it thinks it's flying, and if I mouse over the helicopter and press A or D, the selection box turns slightly like it would if it were actually turning, but only like 5 degrees before it stops.

1 year, 5 months ago

I tried to replicate the error but couldn't. I installed most of the mods, although one of them just failed to load in combination with Electric Furnace mod (I think?)

Error here:
https://gyazo.com/47a354e7b9ec6dded12cb4097b8f590c

In short, sorry... Not much I can do about it. All I can do is mark this as "works for me".

It could be a server-side mis-configuration, but other than that, I can't help you...

Sorry.

1 year, 4 months ago

I think the only mod setting I messed with was in Bob's and mini machines, other than that I kept them all as they were. Thanks for the help though, I'll keep troubleshooting on my own.

1 year, 4 months ago

So, I was trouble shooting and I decided to just run the helicopter mod alone and I still have the same bug, so I think it's not a conflict.

1 year, 4 months ago

Also tried out a new saved with this mod alone and the issue still persists.

1 year, 4 months ago

I'm not sure if it means anything, but the fuel gauge that pops up reads that I have no fuel in it regardless of if I do or not. Last time I used the helicopter mod it didn't have that fuel gauge so I have no idea if it's even supposed to show anything or not.

New response