Resource Map Label Marker

by kizrak

Creates resource map label markers when chunks get generated and charted. See resources through fog of war. Please review settings and consult details below before starting!! πŸš€ #icon #resources #map #reveal #label #markers #chunks #generated #chart #tag #map #ore #count #fog of war

Utilities
4 months ago
0.17 - 1.1
53.1K

b Stopped making icons

3 years ago

Something strange I've just recently noticed. New labels generated don't contain the icons. It just has the 'dot signal' icon. Is there a limit on how many? or how far? or number of surfaces? I'm playing with SE so I don't know if that has something to do with it, but at least not initially.

If I start a new game it works fine. Icons are generated with the patch size (like your screenshots shows). But it stopped doing that sometime.

I've tried it against a dev's game to confirm and his show the same 'issues'.

This is reproducible for me. Only difference is, I'm running the latest factorio version (and all the mods) from his original post.
1. Loaded and sync all mods and settings as the dev's final save game. ( https://imgur.com/a/LdR58ep )
2. View Nauvis ( Just in case you aren't familar with SE... from his save, hit U, Nauvis, View Surface )
3. If you scroll around in map mode, you can see the patches with icons near your initial spawn. But farther away at the edges of the revealed map they are just 'dot signal' icons. So unless he changed them himself, I'm assuming it's the same as what I'm seeing. This is especially noticeable on the far east side.
4. Just for checking, I tried on a newly generated surface/planet. ( Same U. I picked the last listed with resource, 'Galactic Gravel' and viewed surface) Same dot icons.

I do have my save but it's more modded and I wanted to be sure it wasn't something else. The Dev's save game is minimally modded at nearly just vanilla SE. Again, I don't know if this is a SE/surface issue or not. As I have started a brand new SE game and the icons generated fine. So while playing, sometime during gameplay it stops.

3 years ago

Additionally, if I run

/reset-map-tags-and-data "Remove all labels for the given user's force and then re-tag all resources with new labels."

on my or V453000's map, all resource labels are regenerated with only dot signals. Even ones that had the resource icons before.

3 years ago
(updated 3 years ago)

Very interesting... My first thought was that it has issues with the non default Nauvis layer, but you say it will bug out on that after a while? πŸ€” Does it happen on vanilla resources or just modded? Which version of Factorio and the mod(s)?

I'll need to look into this more. πŸ˜€

3 years ago

I'm playing with SE. But it bugs out on regular as well. I started a brand new game and the icons show up fine. If you view V453000's map, you can tell it looked like it bugged out on him eventually as well. The initial icons near his crashed ship spawn all show icons. But the patches that are near the edge of his map show dots.

I'm playing on latest version, 1.1.18? There's been a bunch of updates these past few days. I have a ton of mods so that's why I like checking to see his game exhibits the same issues for reports as he uses very few mods. I've tried running the /reset command and all the labels regenerated with dots. You can see it happen if you load up his game.

Unfortunately I don't know when it started. I just noticed it recently and don't know when it started. I can see the older surfaces I've setup at and do see icons on them. But they are generally small and not very well explored planets. But all new spawn labels now show dots. When I expand farther out on Nauvis and when I visit a new surface or planet.

Nauvis is just my most explored surface. Since my main factory is on it and I'm always expanding to gather more patches. The whole factory must grow thing...

3 years ago

It started to happen to me too.

https://i.imgur.com/euIGurF.png

Old ones still displays properly.

3 years ago
(updated 3 years ago)

Should be "fixed" in releases/tag/0.7.25 πŸ˜€

You may need to run /resourcemarker rebuild then /resourcemarker retag. Sorry if you are using map labels for anything else (this process will destroy them). 😭 See /resourcemarker help for details of new commands.

I was not able to find the cause of the bug 😒, but I was able to address the symptoms. If you see more than one message related to global.aliases missing, please submit a new bug report and let me know what causes it -- this message may happen one time after upgrading the mod as it will try to repair itself.

The only way I believe this could happen is if a global variable got lost, but as the code only assigns it once during script.on_init, I'm not sure how it could ever get cleared/lost except maybe a migration or something. πŸ€”

3 years ago

I updated it, rebuild and retag and I'm seeing icons on all the patches I wasn't before.

If it starts happening again, I'll post up another reply. If it happens to someone else, maybe if they post you can gather more info on why it happened in the first place. But for now, it seems to work.

3 years ago

Excellent! --- glad it is working for you 🧑

New response