Diesel Locomotive deprecated


Adds functionality and a locomotive for using fluids as fuel. Can use heavy oil, light oil, or diesel (if added by another mod), or all three. Configurable in Settings -> Mod Settings. (I am no longer playing this game or supporting this mod. I see someone else made a successor, though: https://mods.factorio.com/mod/dieselTrains)

1 year, 9 months ago
0.15 - 0.17
5001

a Save corruption

3 years ago

If your save is in any way corrupted by using this mod, please post it here or in the diesel locomotive forum thread : the steps to reproduce it, your savegame file, all your mods used, the error message.

3 years ago

My factorio version 0.15.28 don't start if the diesel locomotive mods it's enable.
but if i disable that mod, factorio start but my save no.
My save: http://www.mediafire.com/file/15ptc2a34jprcpt/MyWorld.zip
error when mod is enable: http://www.mediafire.com/file/zwf78clf6zx464x/Cattura.PNG
error when mod is disable: http://www.mediafire.com/file/4zy3zpvv62hrrec/factorio-current.log
mods installed list: http://www.mediafire.com/file/j97xo9f51oknnva/mod-list.json

3 years ago

francesco.fdd5,
try rollback factorio to 0.15.27, then load your save and uninstall 'Diesel Locomotive' mod using the instruction from mod info page:

"To uninstall, use the uninstall button inside the game. If you just disable the mod in the middle of playthrough, it tend to be unplayable afterwards."

Remove mod and update game to last version.
Or play with this mod in factorio 0.15.27 and wait for the author to fix the compatibility problem.

3 years ago

There is no possible fix for compatibility problem, from now on, the author won't be working on this mod at least until the devs re-enable mods to tweak rail_category.

3 years ago

So sad

3 years ago

where is the unistall button