Configurable quick start

by Jorn86

Allows configurable starting equipment, anything from equipment and bots to steam engines and miners

3 years ago
0.17 - 0.18

g First attempt to load game after installing this mod causes load-crash

3 years ago

Savefile was first created but not played in Factorio v0.17.79, other mods present mostly QoL no overhaul mods such as Py or Angel, etc.

All gameplay on this savefile was in Factorio v0.18.4, including mods. Only "user-edited to update to v0.18" was downloaded from another, mod is Angel's Warehouses, no other mod conflicts known to exist. Imgur link is of error at time of first attempt (after installing this mod) to reload savefile. Please advise if more info would be helpful.

PS, checked github link, not entirely sure how to use it to message mod author.

3 years ago

Adding: Mod crash is avoided for starting a new game as opposed to entering a previously saved game.

Perhaps there should be a flag that the mod is keyed to respect at time of install? I imagine alerting the new user that they'd have to choose whether or not to load into an existing savefile would trigger this mod, or if it would lie dormant and unused until the next time someone spawns or respawns into the instance. If this cannot be done by alerting the user at the main options screen, then perhaps keying the flag to a user-edited file within the mod itself where the mod contains commented-out strings to represent all settings, and instructions to the downloader to remove the comment-out terminology to allow one and only one setting string to be recognized at time of client launch?

3 years ago

Can you send me the 0.17.79-generated save file? I doubt the version is the problem as literally nothing changed in between, it's more likely a conflict with other mods. But the save file can tell me that too. Thanks!

3 years ago

I can do that when I'm next at my machine. It occurs to me to troubleshoot by disabling this mod and re-attempt loading the same savefile; and to create a new savefile without this mod being active, to then re-enable it to see if reloading that new savefile with this mod generates the same error. That would at least test my hypothesis that this error might be a result of a simple issue if using this mod for the first time on a previously used savefile.

Will advise with a dropbox link later today. Thanks for the speedy reply.

3 years ago

Hey there, sorry that I let this one lapse. I set up a Dropbox folder at There is the savefile and a minutes-old screenshot.

The savefile was from my attempts to bash my head against a wall with a particular map start with a specific set of design challenges I'd set for myself. I was becoming frustrated at repeated failures, and I noticed that even when re-rolling the exact same Map Exchange String, there could be actual slight differences, such as the exact tile-width of a resource patch. In my own effort to troubleshoot my actions, I decided to re-roll the map one last time and save a "pristine" and unplayed copy of it before proceeding, so that instead of re-rolling (with or without the MES) I could actually go back to the inception of the exact same map roll. shrug

Anyway, since then, obviously, I've migrated to Base v0.18.4 and attempted to incorporate this mod into my efforts. I realize now that adding this new mod would actually make it make sense for me to re-roll the map again entirely, since by using my "pristine copy" of the map, I've technically cheated myself of the benefit of the first go with this mod's behavior. I would ultimately prefer to disallow this mod on subsequent re-spawns, but for purposes of troubleshooting here I did re-enable this mod for re-spawns in the hopes that doing so would allow me to load into the game (at which point I confidently speculate that it would be necessary for me to somehow suicide in order to allow this mod to work for the first time.)

While I've since decided to move on in re-rolling maps anyway, this error here still concerns me. The reason is that, due to some hassles and close calls with my cloudsaved blueprint library (through almost losing it, losing parts of it, or parts of it becoming corrupted but still retrievable) I now maintain actual "hard copies" of my blueprints in a designated chest that I left in my Creative Mod test save. ... I get the same error loading into that save, too. I figure later this week I'll revert Factorio back down to v0.17, reinstall and re-synch the mods for that test map, blueprint everything built, and save the strings to a folder of text files for myself on my Windows desktop. Now that I think of it, that might even be a good idea for going forward than just saving hard copies in a savefile.

So, thanks for making this mod, and have a great evening.

3 years ago
(updated 3 years ago)

Okay, so the crash happens because the freeplay remote interface is not available for some reason. It might have to do with the version update, but since nothing changed since 0.17.79, I don't think that's it. I'll see if I can get some more info here.

I will add a test for this case, and make sure it doesn't crash if it happens. However if the game doesn't provide the freeplay interface, there's not much I can do.

3 years ago
(updated 3 years ago)

Wow, ok. I followed that link, and at the very least, I take as validation that this was neither me overreacting nor me making a knowable mistake. I look fwd to Wube getting back to us on this, what is for me, a rather low-priority issue.

To the awesome persons at Wube who might be reading this: Great game! Thanks for all the work and effort you put in, especially with the v0.18.6 hotfixes and quick turnarounds yesterday!

3 years ago

I guess I have the same issue: "unknown interface: freeplay". Since I am using this as a start-items-modification rather than having specific respawn items, it's not that bad for me (I usually turn the mod off after I started a new map).
PS: even though I don't use it as much, it made the game sooo much more enjoyable because I hate the beginning of the game. This made me play the game a lot more, so thank you for this mod <3

3 years ago

Is it also a game upgraded from 0.17 that causes the error for you? That would point to a strange bug in the 0.17 to 0.18 upgrade. However there hasn't been any response to my forum thread, so I don't think it's worth investigating further.

Glad to hear you're enjoying the mod!

3 years ago

Checking back in to report that all seems well on my end of things, but yeah that does seem sad that it wasn't acknowledged on the forum post.

This thread has been locked.