ScienceCostTweaker Mod (mexmer)

by mexmer
Allows the cost of research to be tweaked, in terms of count, science packs and time. Edit its configs costs *.lua to tweak the multipliers. - Original mod made by UberWafe, this is adopted 0.16 version
a month ago
0.16 - 0.17
61301

b Selecting specific mods freezes factorio

- 2 months ago

(AngelBobs + others)

So I'm not quite sure what's happening, but I think I've narrowed it down to SCT. Basically, when I select specific technologies ( Radar Amplification 2 and Radar Efficiency 2 from Big Brother, and Boiler 5 and Oil Burning Boiler 4 from Bob's Power, there may be more), the game just freezes and stays frozen until I end the process. But what's really strange is that this won't happen unless Angels Petrochem is enabled as well. I can't make sense of it. Enable full AngelBobs and SCT, start a new game, go into the technology tree, search for "boiler" and click boiler 5 to reproduce.

Any ideas? Could it be Angel's mods?

- 2 months ago

except new game start, where script unlocks t1 lab a red science tech, there are no active scripts in SCT (that will react to ingame events) therefore there is nothing in sct that can do such thing.

only thing that comes to my mind, is (and that is not issue of sct), there might be too much dependencies or unlocks on technology you selecting.

i can imagine, if you have enabled science pack connection (which is default setting), then if those technologies happen to be directly connected to science pack, it has too many descendants and game hicups on drawing technology graph, but if that would be source of problem, it will do on selecting any technology of same level. so i doubt, that is the reason. but you might go to mod settings and disable science pack connection and see if it helps.

- 2 months ago

Wow, I think that actually did it lol. Doesn't make any sense, because as you said there's 5 boiler technologies, and 9 radar efficiencies and yet it only crashes upon selecting the 5th and 2nd one in each chain, respectively. But turning off science pack connection fixes it. Thanks a lot mexmer

This thread has been locked.