FNEI

by npo6ka

FNEI mod. All recipes for items and usage for them.

1 year, 1 month ago
0.15 - 1.1
862317

g Selecting an item just shows "recipe_name"

2 years ago

Opening FNEI seems OK, but when I click on an item to find its uses or recipes, it just displays a grey box with "recipe_name" in it in green. This happens both with full AngelBob running and with no other mods running at all. I've tried uninstalling and reinstalling FNEI, but it didn't help. It worked a few weeks ago, so I suspect it may be to do with the latest Factorio build.

2 years ago
(updated 2 years ago)

This because of the latest patch (0.17.56)

  • Removed label style want_ellipsis as it will be used automatically everywhere as with button.
    From the changelog, this seems to be the error.

Removing line 240 from "./scripts/gui.lua" fixes this issue. Hope the author can do this soon :)

2 years ago

Thanks for the workaround, LordXyroz!

2 years ago

Removing line 240 from "./scripts/gui.lua" fixes this issue. Hope the author can do this soon :)

How do you finds that file? I'm looking for it.

2 years ago

it is in the archive file containing the mod.

2 years ago
(updated 2 years ago)

it is in the archive file containing the mod.

And where is that said archive file located? I can't find any folder or file like mentioned above, closest I got was a fnei folder that only containe a .log file.

2 years ago

Look for example at C:\Users\<username>\AppData\Roaming\Factorio\mods\FNEI_0.2.5.zip\FNEI_0.2.5

2 years ago
(updated 2 years ago)

Look for example at C:\Users\<username>\AppData\Roaming\Factorio\mods\FNEI_0.2.5.zip\FNEI_0.2.5

Okay I found it. But how do I edit the file and save it back to where it's supposed to be? I assume you don't extract that file alone to edit, or at least I didn't know what to do next.

Edit: Okay I think I got it. At least it seems to work now. Just extracted the whole zip file, then edited the file and replaced the zip file in the folde with a new one containing the edited file.

2 years ago

Thanks to everyone! I also had to extract the zip file, edit it, then replace, but it worked well!

2 years ago

Thx, working as before :)

2 years ago

Thanks, I did the same.

2 years ago

Any mac users know how I use this to fix it?

2 years ago

Any mac users know how I use this to fix it?

Not a mac user, but I assume it's the same steps, go to where you put your mods in factorio/where you installed fnei into the folder in mods in Factorio and find the same file, edit it, remove line 240 and save it

2 years ago

Hey, I tried that, however the Box is still there, even after patch and reinstall...

2 years ago

Hey, I tried that, however the Box is still there, even after patch and reinstall...

Same here. Try pressing Ctrl-E to reopen the FNEI GUI and to get rid of that box. Worked for me. Thanks LordXyroz! :)

2 years ago
(updated 2 years ago)

Any mac users know how I use this to fix it?

Not a mac user, but I assume it's the same steps, go to where you put your mods in factorio/where you installed fnei into the folder in mods in Factorio and find the same file, edit it, remove line 240 and save it

Thank you for the pointers, kind stranger.

Oh how I wish it was this simple.

Just lost an hour trying to find out where Factorio is installed. Let alone where the mods are. Haven't had any luck (and yes, I worked as a coder for 15 years, so it really REALLY shouldn't be something I struggle with).

Mods on mac are:

  • only installed by the in-game mod menu.
  • hidden inside hidden things in hidden things in archives that don't open unless you force them with a Half-Life 2 crowbar.
2 years ago

I extracted the file and all but I have no clue as to which line is line 240... can you tell me how to identify line 240 AND what does it say exactly so that I can be doubly sure that I am deleting the correct line. Really wish someone could just update the entire file and save me the headache of trying to figure this out and play Factorio this last week without FNEI. Please Help... and thank you in advance.

2 years ago

Found this and it works... got my FNEI back!
https://mega.nz/#!LGoEUCAS!5lCUe_j5kjRbIAiJcFfs3SIHJKTm4Afwx1mPNrgXt78

Fixed version until the author updates.

2 years ago

This because of the latest patch (0.17.56)

  • Removed label style want_ellipsis as it will be used automatically everywhere as with button.
    From the changelog, this seems to be the error.

Removing line 240 from "./scripts/gui.lua" fixes this issue. Hope the author can do this soon :)

Thanks!!

New response