Dumb Robot Repairing Vehicle Fix

Turns off robot construction when driving in vehicle
5 months ago
0.16
255
Owner: ProfoundDisputes
Source: N/A
Homepage: N/A
License: MIT
Created: 5 months ago
Latest Version: 0.5.0 (5 months ago)
Factorio version: 0.16
Downloaded: 255 times

Have you ever found it so frustrating that the personal robots will pop out and start repairing things that you just flew by at 80Km/h+? Maybe you hit a lone tree and was dealt .5 damage? Maybe you have the AutoDeconstruct mod and your miners are marked for deconstruction but you have factories to grow! Maybe you are battling in a tank and your bots are getting decimated! Stop wasting time waiting for them or worse letting them wander around trying to get to you!

Not anymore! This mod disables the construction robots once you speed up in a vehicle. It will be re-enabled once you back up at a certain speed or exit the vehicle. This works with Trains, Tanks and Cars.

NOTE:
-This is my second mod and there may be bugs. This is considered beta!
-When you remove this mod in a save file where your driving at speed some personal roboports may disappear from your equipped armor. It accomplished the disabling by swapping out personal roboports with zero limit roboports.

Mod Compatibility:
-WORKS WITH "Adjustable Personal Roboport Range"! (I made it)
-This mod works by swapping out the personal roboports in the players equipped armor with custom zero robot limit roboports. Due to this, some mods that check personal roboport equipment will have unexpected results.
-Not sure about vehicle mods. You will have to try. If the mod adds a tank with the name of the item containing "tank" than it will work I presume.