Clock


Adds a clock

Utilities
3 years ago
0.13 - 1.1
46.6K

b Error in editor

4 years ago

Just got this error while using editor

Error while running event clock::on_tick (ID 0)
LuaGuiElement API call when LuaGuiElement was invalid.
stack traceback:
clock/control.lua:81: in function <clock/control.lua:63>
stack traceback:
[C]: in function 'index'
__clock
/control.lua:81: in function <clock/control.lua:63>

4 years ago

disabling and reenabling it made me able to load the save again btw

4 years ago

They were some editor issue with the older version of the clock, is it possible that the error could have been caused by loading from a save which last used the older version?

4 years ago

It's new map I've been playing on for a month now, there were some other issues which forced me to edit it with the editor, never had issues with "clock" till then

the error came while editing the map after ~20mins... after that happened I reloaded the same map into the editor again, quickly made the edits I wanted and saved as a scenario.

Starting the scenario as a new game gave me the same error, but it works now after disabling and reenabling it.

I have dozens of other mods, could it be one of them that made "clock" cause that error?

4 years ago

It could be. I've done quite some persistant checks with the clock mod by itself in regards to the editor. Accounting for the editor is a pain in the backside.

New response