Bob's Functions Library mod


Adds a series of useful functions used by Bob's Mods. These can easilly be used by other mods too.

Internal
4 months ago
0.13 - 1.1
367K

b Incompatible with 18.1?

4 years ago

I don't know if i'm doing something wrong, but Factorio claims this mod isn't compatible with the current version. Is this warning bullshit or real?

4 years ago
(updated 4 years ago)

Version 0.18.0 of the library should be compatible with versions 0.18.0 to 0.18.2 of Factorio, and possible future 0.18 versions.

4 years ago

Ok, thanks!

4 years ago

Looks like it's not compatible with 0.18.3?

63.764 Mods to disable:Failed to load mods: boblibrary/technology-functions.lua:123: bad argument #1 of 2 to 'ipairs' (table expected, got nil)
stack traceback:
[C]: in function 'ipairs'
boblibrary/technology-functions.lua:123: in function 'replace_prerequisite'
bobrevamp/data-updates.lua:25: in main chunk

Mods to be disabled:
• bobrevamp

New response