Global Tick Time Scale

by Zanthra

Change the UPS/FPS of Factorio without changing the game pace. Allows normal gameplay at 120hz.

28 days ago
0.15 - 1.1
5785

b HAAAAAALP

1 year, 10 months ago
(updated 1 year, 10 months ago)

I mean... idk? I think you broke your own mod XD
I have been using it for YEARS!! (lol yea yea) whatever
Nah jokes aside ... today i woke up, checked the mods to see if has updates... this one had an update...
So updated...
AND my save its stabled except for my movement speed... im still at early stage (red science and badly) and seems i have 6 exoskeletons XD SUPAH FAST!

The other things seems working at the normal speeds tho and hope you fix it quick XD
::EDIT:: JUST TO CLARIFY!::
If i create a new game, is all good... my save got nutz.. I don't know why this...
::END EDIT:::
In advance,
thank you very much !

1 year, 10 months ago
(updated 1 year, 10 months ago)

Which version of Factorio are you running? The update I made was to make it compatible with factorio 0.17, it should not have affected the 0.16 version though so I would think you are on 0.17 now. On the other hand if you installed the update, and went back to 0.16, then it may be disabled, and you will have to update to the 0.16 version.

Otherwise, can you check what UPS you have the mod set for in the settings, and what UPS you are getting in game?

If it's not the same, try going into the mod settings with the game loaded, and there should be a checkbox for "Reset the UPS to 60". Check that, go back to the game for a second, then go back into settings and deactivate it again. That will force the mod to reset the game speed. The mod does not aggressively maintain the game speed, rather only if the target UPS is changed so that players that want to adjust the game speed themselves still can.

1 year, 10 months ago

I fixed it.. after saying that... i reseted ups to 60 but i couldnt.. caused an error by the way...
But after startup from 120 to 60 than reset ups to normal... went everything to normal... i saved and put that backagain... and everything now works just fine xD

1 year, 10 months ago

Glad to hear you fixed it. Do you recall what the error said? That could help me identity the problem so it does not happen in the future.

1 year, 10 months ago

sadly i don't remember the error ... i may try to reproduce the error and print to you...

New response