Concretexture

by GotLag

Concrete retextured to not look like jumbled stone blocks.

1 year, 8 months ago
0.17 - 1.1
7268

b Concrete (regular and refined) but looks like hazard and not normal concrete

2 years ago
(updated 2 years ago)

concrete ( both normal and refined) are showing up as hazard concrete and not the normal one pictured . I have selected 'rough concrete and refined grid' in the mod settings if that matters.

https://imgur.com/a/xSm1Pmz

also, hazard concrete is missing from crafting menu. not sure what's going on here. A mix up in the code I imagine.

2 years ago

Can you tell me what settings you're using?

2 years ago

I have selected 'rough concrete and refined grid' in the mod settings

2 years ago

it seems that the mod: https://mods.factorio.com/mod/textplates is causing some compatibility issue that is creating this behavior

2 years ago

To be honest I'm not even sure how that happens, given that this mod only changes the sprite that the concrete types display as, and doesn't touch any unlocks or recipes or anything else.

2 years ago

Can you test to see if the missing crafting recipes and hazard stripes persist with Concretexture disabled?

I can't reproduce that issue, with or without textplates enabled. Perhaps it's some other conflict.

2 years ago

yes, the hazard recipes still are missing after disabling concretexture in the save file

2 years ago

i just noticed the same problem after i tried to blueprint some flooring with hazard concrete. some testing showed that i place normal and hazard concrete (for both types of concrete) by cycling through the three variants, using the rotation key. after normal concrete, there is one slant of hazard, then the other slant, fourth is normal again (but seemingly with a different index than the first while on the cursor and identical to the first after placing) and finally again the first normal, the two hazard slants, etc.

i like this method of placing normal and hazard concrete since i no longer need to have different stacks in my inventory, but it gets very annoying and all advantages are lost when i try to use rotated blueprints since they also rotate through all those states and thus mess up all the pretty flooring :-(

i tried several variants of the mod settings, and finally disabled the mod, but the effect stayed the same.
i had installed textplates too, but not enabled it, thus some other mod should be the reason for this problem.

more testing: i found a mod option "Concrete rotates to Hazard" in the mod "Picker Tweaks". thus i finally disabled ALL mods except Picker Tweaks (and its two dependencies Atheneum and stdlib). as result Factorio had a hard crash on loading the map that i was playing before (tested with both, that option turned on and turned off) !

i tried different combinations of mods, and had no more problems. thus i believe that my enabling and disabling of mods got somewhat mixed up, maybe accidentally disabling base too (this should never happen, but maybe by using "sync mods" on loading a map and then switching some mods on/off, it is possible? and/or some other dependencies).

Anyway, here is the TLDR: there seems to be no error in this mod, and the problem is caused by having the option "Concrete rotates to Hazard" in the mod "Picker Tweaks" ENABLED. using hazard concrete gets a bit more difficult (as in vanilla) when DISABLING it, but fixes the problems mentioned in this thread and also fixes any problems with floors and rotated blueprints.

New response